Uploaded image for project: 'XNAT'
  1. XNAT
  2. XNAT-6936

Data types aren't being initialized automatically

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Blocker
    • Resolution: Fixed
    • 1.8.4
    • 1.8.4
    • None
    • None
    • XNAT 2021-Q4 Sprint 2
    • Rank:
      0|0hzyc6:
    • XNAT 2021-Q4 Sprint 2

    Description

      I've got three plugins that all enable data types via annotations in their plugin classes: OHIF, XSync, and FreeSurfer. However, these data types don't seem to be getting setup automatically when tomcat starts anymore. Could be a result of the change here? https://bitbucket.org/xnatdev/framework/commits/28e729b1d77e2c7855806fc5e7dc79b1186ea232.

      That would match the timeframe correctly as while that commit was a month ago, it didn't actually make it into the war until parent was updated https://bitbucket.org/xnatdev/parent/commits/c56631f2049c58b2250b7f389caeddbda251b47a

      Attachments

        Activity

          People

            jrherrick@wustl.edu Rick Herrick
            moore.c@wustl.edu Charlie Moore
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Time Tracking

                Estimated:
                Original Estimate - 0 minutes
                0m
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 2 hours
                2h