Uploaded image for project: 'XNAT'
  1. XNAT
  2. XNAT-6720

Backup of deleted session data is bizarrely hiding each file under a final folder layer with name equal to the file name

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.0.1
    • Fix Version/s: 1.8.1
    • Component/s: Archive Management
    • Labels:
      None
    • Rank:
      0|ii1x73:

      Description

      Sorry for the not great title of this bug but I really can't think of a good way to describe what I'm seeing. I can also confirm that this does not happen in 1.7.6. After the fix for XNAT-6715, I deleted a session (the session is a subset of the files from sample1) and then looked at the backup:

      xnat@xnat-latest:/data/xnat/cache/DELETED/20210317/222747539/data/xnat/archive/FILE_TEST/arc001/Sample_ID/SCANS/4/DICOM$ ls
      1.dcm  2.dcm  3.dcm  scan_4_catalog.xml
      

      This looks fine at first glance, but take a look at the screenshot. What's actually happening is the "1.dcm", "2.dcm", "3.dcm" files are not the original DICOM files at all! Instead, each of those is actually a directory, containing the DICOM file with the same name (i.e. "1.dcm" contains the DICOM file "1.dcm"). This is highly confusing to anyone trying to actually restore their data.

        Attachments

          Activity

            People

            Assignee:
            moore.c@wustl.edu Charlie Moore
            Reporter:
            moore.c@wustl.edu Charlie Moore
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: