Uploaded image for project: 'XNAT'
  1. XNAT
  2. XNAT-5522

Unable to download large image sets

    Details

    • Rank:
      0|ii1jvn:

      Description

      A user on XNAT Central (katal_niraj@yahoo.com) reported:

      I am not able to download OASIS1 and OASIS2 images. Every time I select the images, get an error in both the databases. I download the data after logging into my xnat account. (Error screenshot is enclosed)

      The error occurred on the OASIS1 and OASIS2 images download page while downloading the OASIS cross-sectional and OASIS longitudinal image data. To reproduce the issue:

      1. Select the images
      2. Click on the submit button
      3. You will get the error

      The details of the error are attached in the form of screenshot. And it happens every time while downloading the OASIS1 and OASIS2 images whether a single image is selected or multiple images are selected for downloading.

        Activity

        jrherrick@wustl.edu Rick Herrick created issue -
        jrherrick@wustl.edu Rick Herrick added a comment -

        I suspect the issue is related to performance: it's not the actual download that's timing out, it's building the catalog for the zip download. The confounding addition here is that this occurs with a single image as well, so maybe there's something else going on with it.

        jrherrick@wustl.edu Rick Herrick made changes -
        Field Original Value New Value
        Attachment OASIS1_DownloadError.JPG [ 20156 ]
        Attachment OASIS2_DownloadError.JPG [ 20155 ]
        moore.stephen.m@wustl.edu Steve Moore made changes -
        Sprint 1.7.5-RC-1 [ 117 ]
        moore.stephen.m@wustl.edu Steve Moore made changes -
        Rank Ranked higher
        jrherrick@wustl.edu Rick Herrick made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        moore.stephen.m@wustl.edu Steve Moore made changes -
        Sprint 1.7.5-RC-1 [ 117 ]
        moore.stephen.m@wustl.edu Steve Moore made changes -
        Rank Ranked lower
        moore.stephen.m@wustl.edu Steve Moore made changes -
        Fix Version/s 1.7.5 [ 13913 ]
        Fix Version/s 1.7.6 [ 13912 ]
        moore.stephen.m@wustl.edu Steve Moore made changes -
        Fix Version/s 1.7.6 [ 13912 ]
        Fix Version/s 1.7.5.2 [ 14722 ]
        jrherrick@wustl.edu Rick Herrick made changes -
        Status In Progress [ 3 ] In Progress [ 3 ]
        jrherrick@wustl.edu Rick Herrick made changes -
        Resolution Fixed [ 1 ]
        Assignee Rick Herrick [ rherri01 ] Charlie Moore [ cmoore01 ]
        Status In Progress [ 3 ] Resolved [ 5 ]

          People

          • Assignee:
            moore.c@wustl.edu Charlie Moore
            Reporter:
            jrherrick@wustl.edu Rick Herrick
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: